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Overview
Multi-shaker control (MSC) is a 
unique feature offered by Crystal 
Instruments EDM Software versions 
7.0 and above. The EDM MSC 
function enables users to view and 
monitor multiple shaker tests from 
one PC station. Users can observe 
testing status, view individual signals 
from different shaker systems, and 
send commands to each controller 
from one centralized application. The 
MSC feature is especially useful for 
production applications, resulting in 
increased efficiency and a simplified 
control process. Up to 12 controllers 
can be accessed simultaneously. 
(Figure 1.1, Figure 1.2, and Figure 
1.3)

Users have an option to view the 
composite plot, test status, or both.

MSC Highlights
	● Run different test types 
independently

	● Custom status display

	● Custom individual command panel

	● Common commands for all tests

	● Robust tolerant design

MSC Main Menu 
After connecting to the controllers, 
users can choose from the controller 
list to create a project/test or 
configure/run different tests based on 
each controller selected. In MSC, the 
available menus are Project, Setup, 
View, Layout, Tools, Report, and 
Help.

Project Menu
The purpose of this menu is for 
creating, opening, saving, and 
configuring projects and tests. 
Each project contains up to eight 
tests. Each test is conducted by an 
independent shaker controller. Tests 
are always created under a project 
and managed by a project. For 
example, if a user decides to run two 
sine tests and four random tests with 

six shakers simultaneously; a new project must be created, with six new 

Figure 1.1 MSC Schematic Diagram

Figure 1.2 View Composite from 12 Shakers
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tests under the project. (Figure 1.4)

A test is a collection of configuration 
settings and acquired data. Each 
test operates in one mode, such as 
Random Control, Swept Sine Control, 
or Dynamic Signal Analysis. EDM 
stores test data (e.g., signals,) in 
ATFX format by default in the Run 
Folder. Users can also choose to save 
measured data to the internal flash 
memory of front-end hardware.

New Project starts the New Project 
dialog box and allows users to create 
a new project with a specific project 
name, description, and directory.
Save Project As allows users to 
save a current project and all tests 
under the project as a file on a disk. 
There are two options to save a 
project: “With the run folder” saves 
all previous test data along with the 
project and tests. “Without the run 
folder “saves only the project and 
tests while discarding previous test 
data.

Open Project allows user to browse 
from a disk to open a project file.

Delete Project deletes database 
records only, it will not delete any 
local files. 

Add New Test starts the New Test 
dialog box and allows users to create 
a new test based on manufacturing 
settings or a preconfigured test 
template.

Add/Edit Existing Test allows users 
to open an existing test from the 
database or browse test files from a 
disk.  If a user opens a test file from 
a disk with a duplicated name in the 
database, the software will prompt the 
user with an option to load the test 
and overwrite the existing one in the 
database. 

Save Test will save changes to 
the database. When exiting EDM, 
the contents of the database will 

synchronize automatically to the 
testing file on disk. In other words, 
the test will always be saved. All 
changes made will be saved.

Save Test As allows users to save a 
test under a different name.
Delete Test will delete the test file 
from the database and the disk. Users 
will be asked if they want to delete 
associated data files. 

Lock Test will lock a test in the 
database to prevent accidental 
deletion. A locked test can be 
unlocked afterwards.

Export Run Folder will export all 
signals from the current run folder to 
a directory.

Open Data File will allow users to 

Figure 1.3 Four Tests with Combined View

Figure 1.4 Project Tab



browse from the disk and open data 
files. 

Check List opens the summary of 
critical parameters for review. Users 
have the option to preview this dialog 
box before each test. 

Run History opens a dialog box 
showing recent runs in various 
categories. It is the most efficient 
method to view prior tests in a 
chronological order. The Run 
History window includes all tests’ 
information in each run, such as the 
test name, start/end time, duration, 
test description, run log, and saved 
files. (Figure 1.6)

When there are a large number of 
tests with various types, users enter 
the test name in the search box to find 
and view tests. Click the test name 
hyperlink or open test hyperlink to 
open a currently selected test.

Exit EDM will exit the software. 
If a test is still in progress, the 
software will ask the user to stop the 
test first and then exit. When EDM 
exits, all changes to all the tests are 
automatically saved.

Setup Menu
This menu is used to setup all test 
related parameters such as channel 
tables and test configurations. The 
purpose of these sub-menus is the 
same as described in typical VCS 
tests. (Figure 1.7)

Test Configuration opens a tabbed 
dialog box and allows the user to set 
up all testing parameters. 

Engineering Units allows the user to 
set up the EU as global parameters or 
only for the currently opened test. 

Input Channels opens the channel 
setup dialog box.

Measured Signals opens the 
measured signal dialog box. 

Measured signals are signals that can 
be displayed or stored. 

View Menu
View Menu is used to add display 
windows. Display Windows are 
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Figure 1.5 Create a New Project

Figure 1.6 Run History

Figure 1.7 Setup Tab
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windows used for displaying data 
under the Signal Display tab(s) in the 
main EDM window. This data can 
be from recorded files or real-time 
acquisition in the time domain or 
frequency domain. EDM provides 
a set of default windows to display 
standard data types such as time 
streams, blocks, and frequency 
spectra. Custom window templates 
with user-defined combinations of 
displayed signals can be defined using 
the Save Active Window as User 
Defined command. These custom 
templates are listed at the bottom of 
this menu. (Figure 1.8)

Layout Menu
The Layout menu contains commands 
for opening and closing signal 
display tabs. The current layout of 
tabs can also be saved and opened. 
Each of these tabs contain one or 
more display windows that are 
opened using the View Menu above. 
Commands are provided to arrange 
display windows in the current tab. 
(Figure 1.9)

Tools Menu
This menu contains commands 
for general EDM functions. 
Included commands are hardware 
configuration and calibration, 
database functions, switching EDM 
Working Mode, opening License 
Manager, and opening the Global 
Settings window. (Figure 1.10)

Report Menu
This menu contains commands to 
generate a wide range of testing 
reports, including test data, 
parameters, and users’ notes. (Figure 
1.11)

To create a report template, select the 
(Define Template) menu command.

Hardware System Configuration
Multiple Spider front-ends are 
configured respectively for multiple 
shakers using EDM MSC software. 
Configure a system in the Spider 

System Configuration window by 
selecting the Spider Configuration 
option from the Tools menu. (Figure 
1.12)

Create a New Project and New 
Tests
Click Project->New Project to create 

a new project (as shown in Figure 5). 
The user can specify a project name 
and description for their reference. 
The project directory is the location a 
project is saved to on the local disk. 
This is also the root folder for newly 
saved test files and data files. 

Figure 1.8 View Tab

Figure 1.9 Layout Tab 

Figure 1.10 Tools Tab
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Figure 1.11 Report Tab

Click OK to finish creating the new 
project. The New Test Wizard will 
begin running  immediately to guide 
users to create a new test under the 
newly created project. If additional 
time is required to create a new test, 
press the cancel button to finish 
creating the project without any tests. 
Users can create new tests later by 
clicking the New Test button. (Figure 
1.13)

There are three types of VCS tests 
currently supported in EDM-MSC. 
Additional VCS testing methods will 
be added in future releases.

	● Random

	● Sine on Random/Random on 
Random (SoR/RoR)

	● Swept Sine

The next screen asks users to name 
the test and to select a Spider system 
for the test. (Figure 1.14)

After the first test is created, the 
following main screen of the MSC 
test will be shown as below. (Figure 
1.15)

This screen is divided into five (5) 
parts. On the top is the menu and 
toolbar section. On the left side are 
two sections: recent test list and the 
signal list. On the right side is the test 
control. The middle section includes 
the signal display, status window, and 
control commands.

Users have the option to add test state 
items, control commands, or upload 
shaker images for each test. (Figure 
1.16)

Users can continue to create more 
tests by clicking on Project->New 
Test. After multiple tests are added, 
the main page of the MSC test will be 
displayed as below. (Figure 1.17)
Since each test has its own signal 
display window and control panel, 
the screen size allocated to each test 

is decreased when there are more 
tests. It is highly recommended to use 
a large-size computer monitor with 
a high-resolution display for the best 
viewing experience. (Figure 1.17)

Recent Test List/Signal List
The Recent Test section on the left 
side displays tests recently finished 
under each active project. The Signal 
List shows Live Signals, Run Folders, 

Data Files of a specific test.

Main Control Panel
The main control panel provides 
access to the same actions for all 
tests. The function buttons under the 
main control panel apply to all tests 
under the current project. (Figure 
1.18)

Connect All: connect to all 

Figure 1.12 Create Spider Systems for MSC
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Figure 1.13 Create a New Test

Figure 1.14 The Wizard for a New Random Test

Figure 1.15 Random Test

controllers under the current project. 
Un-detected devices will not be 
connected. This button will only 
connect to detected devices.

Disconnect: disconnect from all 
controllers under the current project.

Run All: start running all the tests.

Stop All: stop running all the tests.

Save Signal All: save the signal of 
each test to its own run folder.

Config: open the test configuration 
window. For details on how to 
configure a test, please refer to the 
Random and Sine chapters of this 
manual.

Individual Control Panel and 
Display
In each test window, there is a signal 
display, status, and control panel as 
shown below. (Figure 1.19)

The function buttons on this control 
panel only apply to this specific 
test and does not affect other tests. 
Only the buttons on the main control 
panel will apply to all tests. Some of 
the following function buttons are 
specific to a random test and/or sine 
test. Therefore, not all buttons will be 
shown on the control panel of each 
test.

Connect: connect to the controller 
of the current test. If the device is not 
detected, this button will be grey out

Run: start running current test

Stop: stop running current test

Set Level: change the current target 
output level to a specified value, as a 
percentage of the test profile

Level Up: increase the current output 
level by 10%

Level Down: decrease the current 
output level by 10%
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Figure 1.16 Select Shaker Photo for a Test

Figure 1.17 Create Four Tests

Figure 1.18 MSC Control Panel

Figure 1.19 Control Panel for test

Restore Level: restore the current 
output level to the level set by the 
current schedule entry

Reset Average: reset all averages to 
zero

Hold Sweep: the sweep in progress at 
the current frequency

Sweep Up: begin sweeping in the 
direction of increasing frequency

Sweep Down: begin sweeping in the 
direction of decreasing frequency

Release Sweep: resume the sweep set 
by the current schedule entry

Set Frequency: dwell at a specified 
frequency

Next Entry: end the current test stage 
and move to the next schedule entry

Pause: pause the test

Save Signal: save the signal to the 
run folder

Custom Display
Users can choose to display one or 
both the control composite and test 
status for high counts of tests. This 
is accomplished in the View menu 
(View-> Test Status of all tests). 
(Figure 1.20)

Custom Command List
Users can also choose to display or 
remove selective commands: right-
click to remove a command or click 
Add… to add a command. (Figure 
1.21)

Instant Warning and Notifications
During testing, warning messages 
or notifications will display in each 
test section. A warning message 
such as user abort, Lost Ctrl Ch will 
display at the top of the test status 
list. Notifications such as save will 
display in a floating window as 
shown below. (Figure 1.22)
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Figure 1.20 Display Test Status Only (Four Tests)

Figure 1.21 Add or Remove a Command

Figure 1.22 Warning/Notification Display

Manipulate a Test
To change the configuration of 
one test or to download saved data 
from internal memory, the specified 
test should be made active first. 
To change the configuration, users 
should first stop the current test. 
(Figure 1.23)

Generate Reports
After a report template is created, 
users may generate the report for all 
tests with one-click. (Figure 1.24)
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Figure 1.23 Active Test Atop (Sin3)

Figure 1.24


